I am trying simple l3vpn here. I am not sure about the procedure of l3vpn on virtual router aspect.
Below are my configs with the error.
interfaces {
em2 {
mtu 1500;
unit 0 {
family inet {
address 10.10.10.2/24;
}
}
}
em4 {
unit 0 {
family inet;
}
}
lo0 {
unit 0 {
family inet {
address 4.4.4.4/32;
}
}
}
}
routing-options {
router-id 4.4.4.4;
autonomous-system 1;
}
protocols {
bgp {
group ibgp {
type internal;
local-address 4.4.4.4;
family inet-vpn {
unicast;
}
neighbor 2.2.2.2;
}
}
ospf {
area 0.0.0.0 {
interface em2.0;
interface lo0.0;
}
}
}
routing-instances {
L3VPN {
instance-type vrf;
interface em2.0;
route-distinguisher 44:44;
vrf-target target:44:44;
vrf-table-label;
}
}
[edit]
root# commit
[edit routing-instances L3VPN]
'interface em2.0'
RT Instance: Interface em2.0 not supported under routing-instances.
error: configuration check-out failed