Hello Folks,
Kind of new to Juniper but slowly working my way through the transition from Cisco to Juniper. Have a problem I just can't seem to wrap my head around with a GRE in a routing-instance.
I have two sites that I'm trying to connected together via a GRE residing inside a routing instance. At the R1 site the GRE is sourced from the loopback lo0.0 and at R3 it's destination is an actual interface. I want to pass OSPF over this tunnel between the two routing instances. The tunnel doesn't appear to be coming up and the OSPF peers don't either since the tunnel never comes up. There is another site that sits between the two sites that functions as part of the transport between the two sites and routing in the global inet.0 is functioning as expected.
R1
root# run show configuration | display set
set version 15.1F3.11
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.10.10.1/30
set interfaces em1 unit 0 family inet address 172.16.1.1/29
set interfaces em2 unit 0 family inet address 172.16.1.2/29
set interfaces em3 unit 0 family inet address 134.123.1.1/24
set interfaces gre unit 100 tunnel source 10.10.10.1
set interfaces gre unit 100 tunnel destination 10.10.10.2
set interfaces gre unit 100 family inet address 192.168.1.1/30
set interfaces gre unit 200 tunnel source 20.20.20.1
set interfaces gre unit 200 tunnel destination 10.10.10.6
set interfaces gre unit 200 family inet mtu 1400
set interfaces gre unit 200 family inet address 192.168.100.1/30
set interfaces lo0 unit 0 family inet address 20.20.20.1/32
set protocols ospf area 0.0.0.0 interface gre.100
set protocols ospf area 0.0.0.0 interface lo0.0
set routing-instances DELTA-CIC instance-type virtual-router
set routing-instances DELTA-CIC interface em1.0
set routing-instances DELTA-CIC interface em3.0
set routing-instances DELTA-CIC protocols ospf area 0.0.0.49 interface em1.0
set routing-instances DELTA-CIC protocols ospf area 0.0.0.49 interface em3.0 passive
set routing-instances NDCS instance-type virtual-router
set routing-instances NDCS interface em2.0
set routing-instances NDCS interface gre.200
set routing-instances NDCS routing-options static route 10.10.10.6/32 next-table inet.0
set routing-instances NDCS routing-options static route 20.20.20.1/32 next-table inet.0
set routing-instances NDCS protocols ospf area 0.0.0.49 interface em2.0
set routing-instances NDCS protocols ospf area 0.0.0.49 interface gre.200
R2
root> show configuration | display set
set version 15.1F3.11
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.10.10.2/30
set interfaces em1 unit 0 family inet address 10.10.10.5/30
set interfaces gre unit 100 tunnel source 10.10.10.2
set interfaces gre unit 100 tunnel destination 10.10.10.1
set interfaces gre unit 100 family inet address 192.168.1.2/30
set interfaces lo0 unit 1 family inet address 20.20.20.2/32
set protocols ospf area 0.0.0.0 interface gre.100
set protocols ospf area 0.0.0.0 interface lo0.1 passive
set protocols ospf area 0.0.0.0 interface em1.0
R3
root# run show configuration | display set
set version 15.1F3.11
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set chassis network-services ethernet
set interfaces em0 unit 0 family inet address 10.10.10.6/30
set interfaces em1 unit 0 family inet address 172.16.2.1/29
set interfaces em2 unit 0 family inet address 172.16.2.2/29
set interfaces em3 unit 0 family inet address 134.123.2.1/24
set interfaces gre unit 200 tunnel source 10.10.10.6
set interfaces gre unit 200 tunnel destination 20.20.20.1
set interfaces gre unit 200 family inet mtu 1400
set interfaces gre unit 200 family inet address 192.168.100.2/30
set protocols ospf area 0.0.0.0 interface em0.0
set routing-instances DELTA-CIC instance-type virtual-router
set routing-instances DELTA-CIC interface em2.0
set routing-instances DELTA-CIC interface em3.0
set routing-instances DELTA-CIC protocols ospf area 0.0.0.0 interface em2.0
set routing-instances DELTA-CIC protocols ospf area 0.0.0.0 interface em3.0 passive
set routing-instances NDCS instance-type virtual-router
set routing-instances NDCS interface em1.0
set routing-instances NDCS interface gre.200
set routing-instances NDCS routing-options static route 20.20.20.1/32 next-table inet.0
set routing-instances NDCS routing-options static route 10.10.10.6/32 next-table inet.0
set routing-instances NDCS protocols ospf area 0.0.0.0 interface em1.0
set routing-instances NDCS protocols ospf area 0.0.0.49 interface gre.200
Any help in figuring this out would be very much appreciated.
Thanks
Mike