Below is the current switch configuration:
## Last changed: 2016-04-03 00:26:03 EDT
version 12.3R12.4;
system {
host-name junos1;
domain-name gsf.home;
domain-search gsf.home;
time-zone America/New_York;
root-authentication {
encrypted-password ".........."; ## SECRET-DATA
}
name-server {
10.10.10.2;
10.10.10.10;
}
services {
ssh {
protocol-version v2;
}
netconf {
ssh;
}
web-management {
http;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
ntp {
server 128.138.141.172 prefer;
}
}
chassis {
aggregated-devices {
ethernet {
device-count 2;
}
}
}
interfaces {
ge-0/0/0 {
description GSF-HV01_01;
ether-options {
802.3ad ae0;
}
}
ge-0/0/1 {
description GSF-PHYESXi01_01;
unit 0 {
family ethernet-switching;
}
}
ge-0/0/2 {
description GSF-PHYESXi01_02;
unit 0 {
family ethernet-switching;
}
}
ge-0/0/3 {
description GSF-HV01_02;
ether-options {
802.3ad ae0;
}
}
ge-0/0/4 {
description GSF-STG01_01;
ether-options {
802.3ad ae1;
}
}
ge-0/0/5 {
description GSF-STG01_02;
ether-options {
802.3ad ae1;
}
}
ge-0/0/6 {
description GSF-STG01_03;
ether-options {
802.3ad ae1;
}
}
ge-0/0/7 {
description GSF-STG01_04;
ether-options {
802.3ad ae1;
}
}
ge-0/0/8 {
disable;
unit 0 {
family ethernet-switching;
}
}
ge-0/0/9 {
disable;
unit 0 {
family ethernet-switching;
}
}
ge-0/0/10 {
description "FIOS NAS";
mtu 9000;
ether-options {
link-mode full-duplex;
speed {
1g;
}
}
unit 0 {
family inet {
address 192.168.1.120/24;
}
}
}
ge-0/0/11 {
description "GSF NAS";
mtu 9000;
ether-options {
link-mode full-duplex;
speed {
1g;
}
}
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members VLAN0010;
}
}
}
}
ge-0/0/12 {
apply-macro juniper-port-profile {
"Routed Uplink";
}
description "FIOS Uplink";
ether-options {
link-mode full-duplex;
speed {
1g;
}
}
unit 0 {
family inet {
address 192.168.1.99/24;
}
}
}
ge-0/0/13 {
disable;
mtu 9000;
ether-options {
link-mode full-duplex;
speed {
1g;
}
}
unit 0 {
family ethernet-switching;
}
}
ge-0/0/14 {
unit 0 {
family ethernet-switching;
}
}
ge-0/0/15 {
unit 0 {
family ethernet-switching;
}
}
ge-0/0/16 {
unit 0 {
family ethernet-switching;
}
}
ge-0/0/17 {
unit 0 {
family ethernet-switching;
}
}
ge-0/0/18 {
disable;
unit 0 {
family ethernet-switching;
}
}
ge-0/0/19 {
disable;
unit 0 {
family ethernet-switching;
}
}
ge-0/0/20 {
ether-options {
link-mode full-duplex;
speed {
100m;
}
}
unit 0 {
family ethernet-switching;
}
}
ge-0/0/21 {
ether-options {
link-mode full-duplex;
speed {
100m;
}
}
unit 0 {
family ethernet-switching;
}
}
ge-0/0/22 {
ether-options {
link-mode full-duplex;
speed {
100m;
}
}
unit 0 {
family ethernet-switching;
}
}
ge-0/0/23 {
ether-options {
link-mode full-duplex;
speed {
100m;
}
}
unit 0 {
family ethernet-switching;
}
}
ge-0/1/0 {
unit 0 {
family ethernet-switching;
}
}
xe-0/1/0 {
description PHYESXi01;
mtu 9000;
unit 0 {
family ethernet-switching {
port-mode trunk;
}
}
}
ge-0/1/1 {
unit 0 {
family ethernet-switching;
}
}
xe-0/1/1 {
description PHYESXi02;
mtu 9000;
unit 0 {
family ethernet-switching {
port-mode trunk;
}
}
}
ge-0/1/2 {
unit 0 {
family ethernet-switching;
}
}
xe-0/1/2 {
description PHYESXi03;
mtu 9000;
unit 0 {
family ethernet-switching {
port-mode trunk;
}
}
}
ge-0/1/3 {
unit 0 {
family ethernet-switching;
}
}
xe-0/1/3 {
description HV01;
mtu 9000;
unit 0 {
family ethernet-switching {
port-mode trunk;
}
}
}
ae0 {
description HV01;
aggregated-ether-options {
lacp {
active;
}
}
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members VLAN0010;
}
native-vlan-id VLAN0010;
}
}
}
ae1 {
description STG01;
aggregated-ether-options {
lacp {
active;
}
}
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members VLAN0010;
}
native-vlan-id VLAN0010;
}
}
}
vlan {
unit 0 {
family inet {
address 10.10.11.1/24;
}
}
unit 1 {
family inet {
address 10.10.110.1/24;
}
}
unit 3 {
family inet {
address 10.20.0.1/24;
}
}
unit 4 {
family inet {
address 10.10.10.1/24;
}
}
}
vme {
unit 0 {
family inet;
}
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop 192.168.1.1;
route 10.10.110.0/24 next-hop 10.10.110.1;
route 10.10.10.0/24 next-hop 10.10.10.1;
route 10.10.11.0/24 next-hop 10.10.11.1;
route 10.20.0.0/24 next-hop 10.20.0.1;
route 192.168.1.121/32 next-hop 192.168.1.120;
}
}
protocols {
igmp-snooping {
vlan all;
}
rstp;
lldp {
interface all;
interface xe-0/1/2.0;
interface xe-0/1/1.0;
interface xe-0/1/0.0;
interface ge-0/0/0.0;
interface ge-0/0/1.0;
interface ge-0/0/2.0;
interface ge-0/0/3.0;
interface ge-0/0/4.0;
interface ge-0/0/5.0;
interface ge-0/0/6.0;
interface ge-0/0/7.0;
}
lldp-med {
interface all;
interface xe-0/1/2.0;
interface xe-0/1/1.0;
interface xe-0/1/0.0;
interface ge-0/0/0.0;
interface ge-0/0/1.0;
interface ge-0/0/2.0;
interface ge-0/0/3.0;
interface ge-0/0/4.0;
interface ge-0/0/5.0;
interface ge-0/0/6.0;
interface ge-0/0/7.0;
}
}
class-of-service {
classifiers {
dscp juniper_dscp_classifier {
import default;
forwarding-class voice {
loss-priority low code-points 101110;
}
}
ieee-802.1 juniper_ieee_classifier {
import default;
forwarding-class voice {
loss-priority low code-points 101;
}
}
}
forwarding-classes {
class voice queue-num 7;
class expedited-forwarding queue-num 5;
class assured-forwarding queue-num 1;
class best-effort queue-num 0;
}
interfaces {
ge-0/0/12 {
scheduler-map juniper-port-profile-map;
unit 0 {
classifiers {
dscp juniper_dscp_classifier;
ieee-802.1 juniper_ieee_classifier;
}
}
}
}
scheduler-maps {
juniper-port-profile-map {
forwarding-class voice scheduler strict-priority-scheduler;
forwarding-class expedited-forwarding scheduler expedited-scheduler;
forwarding-class assured-forwarding scheduler assured-scheduler;
forwarding-class best-effort scheduler best-effort-scheduler;
}
}
schedulers {
strict-priority-scheduler {
buffer-size percent 5;
priority strict-high;
}
expedited-scheduler {
transmit-rate percent 30;
buffer-size percent 30;
priority low;
}
assured-scheduler {
transmit-rate percent 25;
buffer-size percent 25;
priority low;
}
best-effort-scheduler {
transmit-rate percent 35;
buffer-size percent 40;
priority low;
}
}
}
ethernet-switching-options {
voip;
storm-control {
interface all;
}
}
vlans {
VLAN0010 {
description 10GbE;
vlan-id 10;
interface {
xe-0/1/0.0;
xe-0/1/1.0;
xe-0/1/2.0;
xe-0/1/3.0;
ge-0/0/1.0;
ge-0/0/2.0;
ge-0/0/8.0;
ge-0/0/9.0;
ge-0/0/13.0;
ge-0/0/14.0;
ge-0/0/15.0;
ge-0/0/16.0;
ge-0/0/17.0;
ge-0/0/18.0;
ge-0/0/19.0;
ge-0/0/20.0;
ge-0/0/21.0;
ge-0/0/22.0;
ge-0/0/23.0;
}
l3-interface vlan.4;
}
VLAN1020 {
description 10GbE;
vlan-id 1020;
interface {
xe-0/1/0.0;
xe-0/1/1.0;
xe-0/1/2.0;
xe-0/1/3.0;
}
l3-interface vlan.3;
}
VLAN110 {
description 10GbE;
vlan-id 110;
interface {
xe-0/1/0.0;
xe-0/1/1.0;
xe-0/1/2.0;
xe-0/1/3.0;
}
l3-interface vlan.1;
}
default {
description 1GbE;
vlan-id 12;
l3-interface vlan.0;
}
}